Mercurial > hg > anonet-resdb
comparison contrib/ebuilds/quicktun-2.1.7.ebuild @ 1067:35abad495280 draft
new file: contrib/ebuilds/quicktun-2.1.7.ebuild
author | Anonymous Coward <nobody@nowhere> |
---|---|
date | Sat, 01 Dec 2012 21:44:07 +0000 |
parents | |
children | 9b65eafaf2d8 |
comparison
equal
deleted
inserted
replaced
1066:fa75dab42818 | 1067:35abad495280 |
---|---|
1 # Copyright 1999-2012 Gentoo Foundation | |
2 # Distributed under the terms of the GNU General Public License v2 | |
3 # $Header: $ | |
4 | |
5 EAPI=4 | |
6 | |
7 DESCRIPTION="QuickTun is probably the simplest VPN tunnel software ever, yet | |
8 it's very secure. It relies on the NaCl encryption library by D. J. Bernstein." | |
9 HOMEPAGE="http://wiki.ucis.nl/QuickTun" | |
10 SRC_URI="http://oss.ucis.nl/quicktun/src/quicktun-2.1.7.tgz" | |
11 | |
12 LICENSE="GPL-2" | |
13 SLOT="2" | |
14 KEYWORDS="~amd64" | |
15 IUSE="" | |
16 | |
17 DEPEND="dev-lang/nacl-toolchain-newlib" | |
18 RDEPEND="${DEPEND}" | |
19 | |
20 src_compile() { | |
21 NACL_SHARED=1 ./build.sh | |
22 } | |
23 | |
24 src_install() { | |
25 mkdir -p "${D}/usr/sbin/" | |
26 cp out/quicktun.* "${D}/usr/sbin/" | |
27 } |